unix-compat: Portable POSIX-compatibility layer.

[ bsd3, library, system ] [ Propose Tags ]

This package provides portable implementations of parts of the unix package. This package re-exports the unix package when available. When it isn't available, portable implementations are used.

Flags

Automatic Flags
NameDescriptionDefault
split-baseEnabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Versions [RSS] 0.1, 0.1.1, 0.1.2.0, 0.1.2.1, 0.2, 0.2.1, 0.2.1.1, 0.2.1.2, 0.2.1.3, 0.2.2, 0.2.2.1, 0.3, 0.3.0.1, 0.3.0.2, 0.4.0.0, 0.4.1.0, 0.4.1.1, 0.4.1.3, 0.4.1.4, 0.4.2.0, 0.4.3.0, 0.4.3.1, 0.5, 0.5.0.1, 0.5.1, 0.5.2, 0.5.3, 0.5.4, 0.6, 0.7, 0.7.1, 0.7.2 (info)
Dependencies base, directory, old-time, unix (<2.8) [details]
License BSD-4-Clause
Author
Maintainer bjorn@bringert.net
Revised Revision 2 made by sjakobi at 2022-09-29T23:12:15Z
Uploaded by DuncanCoutts at 2007-11-07T14:32:23Z
Distributions Arch:0.7.1, Debian:0.5.2, Fedora:0.7, FreeBSD:0.4.1.4, LTSHaskell:0.7.2, NixOS:0.7.1, Stackage:0.7.2, openSUSE:0.7.1
Reverse Dependencies 84 direct, 4363 indirect [details]
Downloads 227316 total (593 in the last 30 days)
Rating 2.0 (votes: 1) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Docs uploaded by user
Build status unknown [no reports yet]