wai-rate-limit-postgres: See README for more info

[ apache, library, network, security, web ] [ Propose Tags ]

A backend using PostgreSQL for wai-rate-limit.


[Skip to Readme]

Modules

[Index] [Quick Jump]

Downloads

Maintainer's Corner

Package maintainers

For package maintainers and hackage trustees

Candidates

  • No Candidates
Versions [RSS] 0.0.0.0, 0.1.0.0, 0.2.0.0, 0.3.0.0, 0.4.0.0, 0.5.0.0, 0.6.0.0
Change log CHANGELOG.md
Dependencies base (>=4.14 && <5), bytestring (>=0.10 && <0.12), postgresql-simple (>=0.6 && <0.7), resource-pool (>=0.2.3.2 && <0.4), text (>=1.2.4 && <2.1), wai-rate-limit (>=0.3.0.0 && <1.0) [details]
License Apache-2.0
Copyright 2022 Aditya Manthramurthy
Author Aditya Manthramurthy
Maintainer Aditya Manthramurthy <aditya.mmy@gmail.com>
Category Security, Web, Network
Home page https://github.com/donatello/wai-rate-limit-postgres
Bug tracker https://github.com/donatello/wai-rate-limit-postgres/issues
Source repo head: git clone https://github.com/donatello/wai-rate-limit-postgres.git
Uploaded by AdityaManthramurthy at 2022-06-27T23:32:30Z
Distributions NixOS:0.6.0.0
Downloads 188 total (18 in the last 30 days)
Rating 2.0 (votes: 1) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Docs available [build log]
Last success reported on 2022-06-28 [all 1 reports]

Readme for wai-rate-limit-postgres-0.6.0.0

[back to package description]

wai-rate-limit-postgres

GitHub CI Hackage Apache-2.0 license

This is a companion package to wai-rate-limit that adds support to use PostgreSQL as a backend.

Depending on traffic and latency of PostgreSQL, this backend may or may not be appropriate for you.

Testing locally with Docker

Start a PostgreSQL docker container in a terminal:


$ docker run --name some-postgres -e POSTGRES_PASSWORD=postgres -p 5432:5432 -it --rm postgres -c log_statement=all

Run tests in another terminal with:


$ export PG_DB_URI=postgres://postgres:postgres@localhost:5432/postgres
$ cabal test