exception-transformers: Type classes and monads for unchecked extensible exceptions.

[ bsd3, control, error-handling, failure, library, monad ] [ Propose Tags ]

This package provides type classes, a monad and a monad transformer that support unchecked extensible exceptions as well as asynchronous exceptions. It is compatible with the transformers package.

Versions [RSS] [faq] 0.2, 0.3, 0.3.0.1, 0.3.0.2, 0.3.0.3, 0.3.0.4, 0.4, 0.4.0.1, 0.4.0.2, 0.4.0.3, 0.4.0.4, 0.4.0.5, 0.4.0.6, 0.4.0.7, 0.4.0.8, 0.4.0.9, 0.4.0.10, 0.4.0.11
Dependencies base (==4.*), transformers (>=0.2 && <0.6), transformers-compat (>=0.3 && <0.8) [details]
License BSD-3-Clause
Copyright (c) 2009-2010 Harvard University (c) 2011-2021 Geoffrey Mainland
Author Geoffrey Mainland <mainland@drexel.edu>
Maintainer Geoffrey Mainland <mainland@drexel.edu>
Revised Revision 1 made by GeoffreyMainland at 2021-10-25T16:21:23Z
Category Control, Monad, Error Handling, Failure
Bug tracker https://github.com/mainland/exception-transformers/issues
Source repo head: git clone git://github.com/mainland/exception-transformers.git
Uploaded by GeoffreyMainland at 2021-07-28T13:12:53Z
Distributions Debian:0.4.0.7, LTSHaskell:0.4.0.11, NixOS:0.4.0.10, Stackage:0.4.0.11
Downloads 22452 total (250 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs available [build log]
Last success reported on 2021-07-28 [all 1 reports]

Modules

[Index] [Quick Jump]

Downloads

Note: This package has metadata revisions in the cabal description newer than included in the tarball. To unpack the package including the revisions, use 'cabal get'.

Maintainer's Corner

For package maintainers and hackage trustees

Candidates