hackage-security-HTTP: Hackage security bindings against the HTTP library

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain] [Publish]

The hackage security library provides a HttpLib abstraction to allow to bind against different HTTP libraries. This library implements this abstraction using the HTTP library.

Properties

Versions 0.1.0.0, 0.1.0.1, 0.1.0.2, 0.1.1, 0.1.1.1, 0.1.1.1
Change log ChangeLog.md
Dependencies base (>=4.5 && <4.15), bytestring (>=0.9 && <0.11), hackage-security (>=0.5 && <0.7), HTTP (>=4000.2.19 && <4000.4), mtl (>=2.1 && <2.3), network (>=2.5 && <2.9 || >=3.0 && <3.2), network-uri (==2.6.*), zlib (>=0.5 && <0.7) [details]
License BSD-3-Clause
Copyright Copyright 2015-2016 Well-Typed LLP
Author Edsko de Vries
Maintainer cabal-devel@haskell.org
Category Distribution
Home page https://github.com/haskell/hackage-security
Bug tracker https://github.com/haskell/hackage-security/issues
Source repo head: git clone https://github.com/haskell/hackage-security.git
Uploaded by HerbertValerioRiedel at 2020-11-02T23:17:07Z

Modules

[Index]

Manual Flags

NameDescriptionDefault
Automatic Flags
NameDescriptionDefault
use-network-uri

Are we using network-uri?

Enabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees