BlogLiterately: A tool for posting Haskelly articles to blogs

This is a package candidate release! Here you can preview how this package release will appear once published to the main package index (which can be accomplished via the 'maintain' link below). Please note that once a package has been published to the main package index it cannot be undone! Please consult the package uploading documentation for more information.

[maintain] [Publish]

Write blog posts in Markdown format, then use BlogLiterately to do syntax highlighting, format ghci sessions, and upload to any blog supporting the metaWeblog API (such as Wordpress): http://codex.wordpress.org/XML-RPC_MetaWeblog_API.

To get started, use the provided executable BlogLiterately; see http://byorgey.wordpress.com/blogliterately/ for complete documentation.

To make further customization possible, the internals of the executable are made available as a library. In particular, it is easy to create your own executable which adds extra custom transformations; see Text.BlogLiterately.Run.


[Skip to Readme]

Properties

Versions 0.2, 0.3, 0.4, 0.5, 0.5.1, 0.5.2, 0.5.2.1, 0.5.3, 0.5.4, 0.5.4.1, 0.6, 0.6.0.1, 0.6.0.2, 0.6.1, 0.6.2, 0.6.3, 0.6.3.1, 0.7, 0.7.0.1, 0.7.0.2, 0.7.1, 0.7.1.1, 0.7.1.2, 0.7.1.3, 0.7.1.4, 0.7.1.5, 0.7.1.6, 0.7.1.7, 0.7.1.8, 0.7.1.9, 0.7.1.10, 0.7.1.11, 0.8, 0.8.1, 0.8.1.1, 0.8.1.2, 0.8.1.3, 0.8.1.4, 0.8.1.5, 0.8.1.6, 0.8.2, 0.8.2.1, 0.8.2.2, 0.8.2.3, 0.8.3, 0.8.3.1, 0.8.4, 0.8.4.1, 0.8.4.2, 0.8.4.3, 0.8.5, 0.8.6, 0.8.6, 0.8.6.1, 0.8.6.2, 0.8.6.3, 0.8.7
Change log CHANGES.md
Dependencies base (>=4.0 && <4.11), blaze-html (>=0.5 && <0.10), BlogLiterately, bool-extras, bytestring, cmdargs (>=0.9.5 && <0.11), containers, data-default (>=0.5 && <0.8), directory, filepath, HaXml (>=1.22 && <1.26), haxr (==3000.11.*), highlighting-kate (>=0.5 && <0.7), hscolour (>=1.20 && <1.25), HTTP (==4000.3.*), lens (>=3.8 && <4.17), mtl, pandoc (>=2.0 && <2.2), pandoc-citeproc (>=0.1.2 && <0.15), pandoc-types (>=1.16 && <1.20), parsec (>=3 && <3.2), process, split (>=0.1.4 && <0.3), strict (==0.3.*), tagsoup (>=0.13.4 && <0.15), temporary (>=1.1 && <1.3), text (==1.2.*), transformers (>=0.3 && <0.6) [details]
License GPL-3.0-only
Copyright Copyright (c) Robert Greayer 2008-2010, Brent Yorgey 2012-2016
Author Robert Greayer <robgreayer@yahoo.com>, Brent Yorgey
Maintainer Brent Yorgey <byorgey@gmail.com>
Category Web
Home page http://byorgey.wordpress.com/blogliterately/
Bug tracker http://github.com/byorgey/BlogLiterately/issues
Source repo head: git clone git://github.com/byorgey/BlogLiterately.git
Uploaded by BrentYorgey at 2018-01-31T14:20:29Z

Modules

[Index]

Downloads

Maintainer's Corner

For package maintainers and hackage trustees


Readme for BlogLiterately-0.8.6

[back to package description]

Build Status

Write blog posts in Markdown format, then use BlogLiterately to do syntax highlighting, format ghci sessions, and upload to any blog supporting the metaWeblog API (such as Wordpress).

To get started, use the provided executable BlogLiterately; see http://byorgey.wordpress.com/blogliterately/ for complete documentation.

To make further customization possible, the internals of the executable are made available as a library. In particular, it is easy to create your own executable which adds extra custom transformations; see Text.BlogLiterately.Run.