bindings-libpci: Low level bindings to libpci

[ bsd3, ffi, library ] [ Propose Tags ]

Low level bindings to libpci:

https://github.com/pciutils/pciutils

This package uses bindings-DSL and conforms to its naming convention.


[Skip to Readme]
Versions [RSS] [faq] 0.1.0.0, 0.2.0.0, 0.3.0.0, 0.4.0.0, 0.4.0.1
Change log CHANGELOG.md
Dependencies base (>=4.12 && <4.16), bindings-DSL (>=1.0.24 && <1.1) [details]
License BSD-3-Clause
Copyright Copyright (c) 2020 David Cox
Author dopamane
Maintainer dopamane <standard.semiconductor@gmail.com>
Category FFI
Bug tracker https://github.com/standardsemiconductor/bindings-libpci/issues
Source repo head: git clone https://github.com/standardsemiconductor/bindings-libpci -b main
Uploaded by dopamane at 2021-06-19T17:27:03Z
Distributions NixOS:0.4.0.1
Downloads 490 total (10 in the last 30 days)
Rating (no votes yet) [estimated by Bayesian average]
Your Rating
  • λ
  • λ
  • λ
Status Hackage Matrix CI
Docs uploaded by user [build log]
All reported builds failed as of 2021-06-19 [all 2 reports]

Modules

[Index] [Quick Jump]

Manual Flags

NameDescriptionDefault
Automatic Flags
NameDescriptionDefault
libpci-352

libpci is 3.5.2 or later

Disabled
libpci-353

libpci is 3.5.3 or later

Disabled
libpci-355

libpci is 3.5.5 or later

Disabled
libpci-360

libpci is 3.6.0 or later

Disabled
libpci-363

libpci is 3.6.3 or later

Disabled
libpci-364

libpci is 3.6.4 or later

Disabled
libpci-370

libpci is 3.7.0 or later

Disabled

Use -f <flag> to enable a flag, or -f -<flag> to disable that flag. More info

Downloads

Maintainer's Corner

For package maintainers and hackage trustees

Candidates


Readme for bindings-libpci-0.4.0.1

[back to package description]

bindings-libpci

Haskell CI Hackage Hackage Dependencies

Low level bindings to libpci See also the pciutils homepage.

This package uses bindings-DSL and conforms to its naming convention.

For a higher-level and more Haskell friendly example (which uses this package) see the pci repo.

Prerequisite

Make sure the libpci C library is installed:

  • Ubuntu Linux: sudo apt install libpci-dev
  • Arch Linux: sudo pacman -S pciutils

Build

cabal build -flibpci-vvv